Jump to content


Virtual Drive "Invalid Device Number"


  • Please log in to reply
18 replies to this topic

#1 Trial User_Trial User_Jason_*_*

Trial User_Trial User_Jason_*_*
  • Guests

Posted 04 November 2006 - 05:45 PM

I installed the trial version of Alcohol 120%, and when I try to create a virtual drive, I get an error that says "Invalid device number was specified". I've also been having similar trouble with other emulation software,so it's especially frustrating. I uninstalled all my other burning and mounting software and reinstalled, but no luck. Any ideas? Thanks.

-- Jason Ramboz


{System report removed by ptolomeus3]

#2 ptolomeus3

ptolomeus3

    Forum Support

  • Support Team
  • 5,144 posts

Posted 05 November 2006 - 05:37 AM

QUOTE (zamiel @ Oct 25 2006, 07:56 PM) <{POST_SNAPBACK}>
Do you have Nero Drive Image or INCD installed per chance? Try uninstalling burning apps, installing Alcohol then reinstalling them.


#3 Trial User_Trial User_Jason_*_*

Trial User_Trial User_Jason_*_*
  • Guests

Posted 05 November 2006 - 07:49 AM

QUOTE (ptolomeus3 @ Nov 5 2006, 12:34 PM) <{POST_SNAPBACK}>
QUOTE (zamiel @ Oct 25 2006, 07:56 PM) <{POST_SNAPBACK}>

Do you have Nero Drive Image or INCD installed per chance? Try uninstalling burning apps, installing Alcohol then reinstalling them.



I tried that already. I had Nero Drive Image installed, but I uninstalled it and rebooted (several times) before installing Alcohol. Is there any way to make sure it's fully uninstalled and no traces are remaining?

-- Jason

#4 ptolomeus3

ptolomeus3

    Forum Support

  • Support Team
  • 5,144 posts

Posted 05 November 2006 - 08:23 AM

To manually remove Alcohol, please adopt following steps:
1.run "regedit"
2.Find "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{E9F81423-211E-46B6-9AE0-38568BC5CF6F}", then delete that.
3.Find "HKEY_CLASSES_ROOT\Installer\Products\32418F9EE1126B64A90E8365B85CFCF6", then delete that.

Then to remove Alcohol driver you need to start Regedit then go to HKey_Local_Machine\System\CurrentControlSet\Services here you should find the Keys for the Alcohol Driver in version 1.9.2.1705, 1.9.5.2722 or 1.9.5.2802 a347scsi and a347bus, or in version 1.9.5.3105 vax347s and vax347b, delete these Keys and remove corresponding files from Windows\System32\Drivers folder.

Re boot your PC.

#5 Charalambos

Charalambos

    Support Team Member

  • Support Team
  • 4,880 posts

Posted 05 November 2006 - 11:03 AM

Ptolomeus, I think he talks about the Nero Drine Image, not Alcohol.

Jason, do you receive a message saying "Alcohol's device drivers loading failed" e.t.c. when you run Alcohol?

#6 Trial User_Trial User_Jason_*_*

Trial User_Trial User_Jason_*_*
  • Guests

Posted 05 November 2006 - 02:56 PM

QUOTE (Charalambos @ Nov 5 2006, 06:00 PM) <{POST_SNAPBACK}>
Ptolomeus, I think he talks about the Nero Drine Image, not Alcohol.


Yes, I meant Nero, sorry.

QUOTE (Charalambos @ Nov 5 2006, 06:00 PM) <{POST_SNAPBACK}>
Jason, do you receive a message saying "Alcohol's device drivers loading failed" e.t.c. when you run Alcohol?


No I don't. The program starts with no problems. Then I go to the Virtual Drive options, change the number of Virtual Drives from 0 to 1, click OK, and get the "Invalid device number" error.

-- Jason

#7 ptolomeus3

ptolomeus3

    Forum Support

  • Support Team
  • 5,144 posts

Posted 05 November 2006 - 04:19 PM

Try this:
* uninstall Nero,
* delete all registries of Alcohol (the problem may be caused by remnants of registries)
* reboot
* install Alcohol again.

#8 Trial User_kronus97_*

Trial User_kronus97_*
  • Guests

Posted 05 November 2006 - 09:12 PM

I have the same problem with getting "Invalid Device Number was Specified" when I try to add a virtual drive. I have no other burning software (i.e. nero) on my computer and I've uninstalled and reinstalled a couple times...no luck...any help

#9 zamiel

zamiel

    Forum Support

  • Administration
  • 8,841 posts

Posted 05 November 2006 - 09:48 PM

@kronus97

http://forum.alcohol...showtopic=23848

#10 Trial User_kronus97_*

Trial User_kronus97_*
  • Guests

Posted 06 November 2006 - 12:54 AM

also, I've have problems with SCSI/RAID host controller...I don't know if that has anything to do with it. in device manager SCSI/RAID Host Controller has a "!" by it and it's the only one in it's catagory, tried disabling it, tried removing it, rebooted each time. Nothing seems to work. This computer was just built two days ago with minimal software...

System report removed by zamiel

#11 Trial User_kronus97_*

Trial User_kronus97_*
  • Guests

Posted 06 November 2006 - 10:27 AM

thanks for your help zamiel...or no help i should say. I got Daemon Tools v4.06 to work. So I don't think i'll be buying alcohol 120...trial didn't go so well...

#12 Charalambos

Charalambos

    Support Team Member

  • Support Team
  • 4,880 posts

Posted 06 November 2006 - 11:15 AM

QUOTE
in device manager SCSI/RAID Host Controller has a "!" by it and it's the only one in it's catagory, tried disabling it, tried removing it, rebooted each time.


It is surely the Alcohol's one. You can try the following as it has already been posted:

QUOTE (ptolomeus3 @ Nov 6 2006, 12:16 AM) <{POST_SNAPBACK}>
Try this:
* delete all registries of Alcohol (the problem may be caused by remnants of registries)
* reboot
* install Alcohol again.


#13 zamiel

zamiel

    Forum Support

  • Administration
  • 8,841 posts

Posted 07 November 2006 - 02:52 AM

@Kronus97

I removed the report just before I went to bed. I am entitled to sleep you know tongue.gif and I spent most of the day in court persuing money from a client who hasn't paid me a cent over six months, so......

#14 Trial User_Guest_*

Trial User_Guest_*
  • Guests

Posted 14 November 2006 - 02:40 AM

QUOTE (kronus97 @ Nov 6 2006, 07:51 AM) <{POST_SNAPBACK}>
also, I've have problems with SCSI/RAID host controller...I don't know if that has anything to do with it. in device manager SCSI/RAID Host Controller has a "!" by it and it's the only one in it's catagory, tried disabling it, tried removing it, rebooted each time. Nothing seems to work. This computer was just built two days ago with minimal software...

System report removed by zamiel


i have the same problem too
i installed alcohol 52% freeware

#15 Phoenix

Phoenix

    120% Member

  • +Alcohol-Customer
  • 6,524 posts

Posted 14 November 2006 - 09:20 AM

@kronus97

QUOTE
thanks for your help zamiel...or no help i should say. I got Daemon Tools v4.06 to work. So I don't think i'll be buying alcohol 120...trial didn't go so well...


As Zamiel said
QUOTE
I am entitled to sleep you know
you cant expect ppl to be here 24\7 as Dtools and Alc use the same drivers your problem was not restricted to Alcohol, possibly uninstalling the drivers and re installing, which is basicaly what you have done by installing dtools would have had the same effect.


QUOTE
i have the same problem tooi installed alcohol 52% freeware


Try re installing using safe mode.

#16 Trial User_Max_imum_*

Trial User_Max_imum_*
  • Guests

Posted 14 November 2006 - 02:16 PM

QUOTE (Phoenix @ Nov 14 2006, 04:17 PM) <{POST_SNAPBACK}>
@kronus97

QUOTE
thanks for your help zamiel...or no help i should say. I got Daemon Tools v4.06 to work. So I don't think i'll be buying alcohol 120...trial didn't go so well...


As Zamiel said
QUOTE
I am entitled to sleep you know
you cant expect ppl to be here 24\7 as Dtools and Alc use the same drivers your problem was not restricted to Alcohol, possibly uninstalling the drivers and re installing, which is basicaly what you have done by installing dtools would have had the same effect.


QUOTE
i have the same problem tooi installed alcohol 52% freeware


Try re installing using safe mode.



dont function! no idea what is the problem
allways the same problem by alcohol 52% and daemon tools ??

http://members.chell...ausr/device.zip

regards Max

#17 Trial User_Guest_*

Trial User_Guest_*
  • Guests

Posted 15 November 2006 - 09:09 AM

it is possible to use for alcohol 52% another virtual CD-ROM drive as Sptd driver 1.35 ???

thx
regards

#18 Trial User_Guest_*

Trial User_Guest_*
  • Guests

Posted 15 November 2006 - 10:25 AM

QUOTE (kronus97 @ Nov 6 2006, 07:51 AM) <{POST_SNAPBACK}>
also, I've have problems with SCSI/RAID host controller...I don't know if that has anything to do with it. in device manager SCSI/RAID Host Controller has a "!" by it and it's the only one in it's catagory, tried disabling it, tried removing it, rebooted each time. Nothing seems to work. This computer was just built two days ago with minimal software...

System report removed by zamiel


#19 Trial User_Gelders_*

Trial User_Gelders_*
  • Guests

Posted 15 November 2006 - 10:31 AM

[quote name='Guest' date='Nov 15 2006, 05:22 PM' post='124577']
[quote name='kronus97' post='124089' date='Nov 6 2006, 07:51 AM']
also, I've have problems with SCSI/RAID host controller...I don't know if that has anything to do with it. in device manager SCSI/RAID Host Controller has a "!" by it and it's the only one in it's catagory, tried disabling it, tried removing it, rebooted each time. Nothing seems to work. This computer was just built two days ago with minimal software...

System report removed by zamiel


Helpdesk gave me the following link:
"try downloading the standalone SPTD installer http://www.duplexsecure.com/downloads/ then once downloaded run it and choose uninstall, then reboot and try again to install Alcohol."
Worked well for me smile.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users