Jump to content


New version Alcohol Released

  • This topic is locked This topic is locked
5 replies to this topic

#1 Phoenix


    120% Member

  • +Alcohol-Customer
  • 6,524 posts

Posted 24 April 2009 - 01:25 PM

Today we have released a new version of Alcohol this version now supports Windows 7 for those of you using Windows 7 beta


NEW Supports Windows 7 Beta versions

UPDATE Read and Write engines
UPDATE Language files
UPDATE Devsupp.dll offering support for more drives

FIX User reported bugs

#2 Star Mage

Star Mage

    1% Member

  • Members
  • Pip
  • 3 posts

Posted 24 April 2009 - 02:22 PM

What about the release candidate build 7100? I'm assuming it would probably work but it is a newer build than previously which is what you guys were saying about development for betas. So I just thought I would ask. Thanks.

Edited by Star Mage, 24 April 2009 - 02:32 PM.

#3 Phoenix


    120% Member

  • +Alcohol-Customer
  • 6,524 posts

Posted 24 April 2009 - 11:35 PM

Yes there should not be a problem with the latest Windows 7 Beta, If you were a purchased user you would have had access to more information about development for Windows 7, our purchased users have had access to a limited windows 7 compatible beta version for a few weeks now.

#4 humbled


    1% Member

  • Members
  • Pip
  • 2 posts

Posted 12 May 2009 - 05:46 AM

While I was installing Windows 7 RC and it warned me Alcohol 120 was not compatible with the current version of Alcohol installed on my computer. So upgraded Alcohol 120 to the latest version which had in it's change log that it was fixed to be compatible with Windows 7. Once I upgraded Alcohol I was able to upgrade to Windows 7RC with no warnings. I thought everything was ok until I went to use Alcohol. First thing, key was not valid. I logged into my account and deactivated and deleted the key and re-registered no problem.

Then I started getting an error on Alchol startup about not being able to start a driver (don't remember the details). So I decided to un-install and re-install. When I tried to un-install, I got a message, that I would have to reboot. I rebooted and nothing happened. I noticed a little anoying feature of Windows 7 that I turned off in xp called (UAC) user account control so I turned this off thinking this was part of the problem. I tried un-installing again and it would not un-install. So I found a forum message that gave instructions how to un-install. I went through the instructions but the instructions did not appear to be up to date as some of the keys referenced were not there so I don't know if I un-installed correctly.

Now I try to install and I get a dialog to select language, I select English and it comes back with a message "You must reboot after previous operation". So I reboot and nothing happens. Now I can't un-install or install....
I suspect the problem might be that the application may not be fully un-installed. Can anyone help me with manual un-install instructions with this version?

Basically what has worked so far is
1.Stop Starwind Service and delete service key. delete directory. <---Worked
2.Find "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{E9F81423-211E-46B6-9AE0-38568BC5CF6F}", then delete that. <---- worked
3.Find "HKEY_CLASSES_ROOT\Installer\Products\32418F9EE1126B64A90E8365B85CFCF6", then delete that. <--- Couldn't find this

Then to remove Alcohol driver you need to start Regedit then go to HKey_Local_Machine\System\CurrentControlSet\Services here you should find the Keys for the Alcohol Driver in version, or a347scsi and a347bus, or in version vax347s and vax347b, delete these Keys and remove corresponding files from Windows\System32\Drivers folder. <--- Couldn't find this

Thanks for any help.

#5 humbled


    1% Member

  • Members
  • Pip
  • 2 posts

Posted 12 May 2009 - 06:30 AM

Just as a follow up to my previous post. I was stuck in a loop that would not allow me to re-install. It kept telling me to reboot.
I also booted in Safe Mode and manually installed SPTD 1.5.8. Installed fine but when I went to install alcohol 7612 it kept telling me to reboot (still the same loop).

After searching google some more I found a reference to an older fix and tried it and it worked. I am reposting here so if anyone else is having a problem with this version they will know this is still a valid solution:

After deleting the r value in the key HKLM\SOFTWARE\0d79c293c1ed61418462e24595c90d04 I was able to install Alcohol 120%.

It now looks like it's working.

#6 zamiel


    Forum Support

  • Administration
  • 8,841 posts

Posted 27 August 2009 - 08:24 PM


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users